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It is critical that content is accessible to the widest possible audience and complies with 
accessibility standards and regulations, such as WCAG 2.0 and Section 508 of the U.S. 
Government’s Rehabilitation Act. An “accessible” electronic document is one that is optimized for 
screen readers and other assistive devices used by persons with disabilities. Producing accessible 
content also plays a key role in optimizing PDF documents for successful indexing by Internet 
search engines. 

Achieving this kind of accessibility requires tagging all document content based on its hierarchical 
structure (headings, paragraphs, lists, tables, and so on) and ordering the content in a linear path 
from start to finish. An additional requirement for accessible documents is identifying nontext 
content, such as graphics and images, in context and describing what is shown. 

InDesign offers a direct and simple workflow that dramatically reduces the time and effort required 
to produce accessible PDF documents from an InDesign layout. Most of the tasks are executed 
within InDesign, with only a few final steps required in Adobe Acrobat. This allows hierarchical and 
structural information to reside in the InDesign file, making updates faster and easier when you 
need to generate a revised accessible PDF document. 

Prerequisites 
To create an accessible PDF, you need the following: 

• InDesign to prepare a document for accessible PDF export using the process described in 
this article. 

• Acrobat to finalize the accessibility process. You cannot accomplish these steps with the 
free Adobe Reader application. 

Workflow for creating accessible PDFs 

 
Figure 1. Workflow for creating accessible PDFs 

You can perform the majority of the work necessary to properly structure and prepare a document 
for accessibility can be done directly in InDesign, reducing the post-export work required in Acrobat 
to just a few steps. You can specify the document’s structural hierarchy and content order in the 



InDesign document, which preserves that structure should you need to later modify the document 
and export a new PDF. 

Required steps in InDesign 
• Use paragraph styles consistently throughout your document 

o Consistent use of InDesign paragraph styles throughout a document is critical for 
efficiently and successfully exporting the content to PDF. Base styles on their 
hierarchical structure (main headline, secondary headings, subheading, and so on) 
and apply them appropriately to paragraphs according to their hierarchical role in 
the document. 

• Establish export tag relationships between InDesign styles and PDF tags 
o As you create InDesign styles, set each style’s Export Tagging (in the Paragraph 

Style Options dialog) according to its role in the PDF document— paragraph (P), 
heading levels 1 through 6 (H1–H6), or Artifact. Tables and bulleted and numbered 
lists are recognized automatically in the export process and tagged appropriately. 

• Anchor images within the content flow 
o Images in a print layout can appear anywhere in a spread, and sighted users can 

make the connection between the image and relevant text as they read. Screen 
readers process content in a linear fashion. Because screen readers use text-to-
speech facilities to describe images, they should be placed as close as possible to 
the text that pertains to the image. InDesign’s drag-and-drop object anchoring 
makes it simple to place the reference to the image in an appropriate location 
without affecting the print layout. 

• Add alternative text for images 
o Screen readers can only indicate the presence of an image. Conveying what the 

image depicts requires providing alternative text (alt text). With the Object Export 
Options in InDesign, you can specify alt text from metadata in an image file or add 
custom alt text to any image, graphic, or group of objects in a layout. 

• Incorporate internal document navigation mechanisms 
o In an accessible PDF, tables of contents, bookmarks, hyperlinks, and cross-

references can act as navigation mechanisms to the referenced content. They also 
allow screen reader users to efficiently navigate the document by using the links 
these mechanisms create. 

• Establish content order in the Articles panel 
o The tagging order of a PDF document is essential to its readability. The Articles 

panel in InDesign enables you to precisely define which content in your document 
gets tagged and in what order. You can add content by dragging and dropping frames 
and objects into the Articles panel and then arranging them in the desired reading 
order. You can also break the content up into smaller articles without affecting the 
page layout. 

• Specify a document title and description as metadata 
o For accessibility, as well as for search engine optimization, a PDF file requires a 

document title and a description of its contents. When you save this information in 



the InDesign File Information dialog, it is automatically transferred to Acrobat as 
required metadata. 

• Export as PDF with settings optimized for accessibility 
o When you use the InDesign PDF export options (print or interactive), the tagging, 

organizing, and bookmarking established in the layout become the tagging 
structure, order, and navigation scheme of the resulting PDF document. 

Required steps in Acrobat 
• Set the language in Document Properties 

o You cannot set the document’s language in InDesign. You must specify the language 
in the Advanced options of the Acrobat Document Properties dialog. 

• Change display name from Filename to Document Title 
o By default, Acrobat displays the PDF filename in the title bar of the document 

window. For accessibility purposes, this should be replaced by the document title 
established in InDesign’s File Information dialog. To do so, choose Document Title 
instead of Filename in the Initial View options of Acrobat Document Properties 
dialog. 

• Set the tab order to use the document structure in the Page Thumbnails pane 
o The structure established in the InDesign Articles panel is saved in the exported PDF 

file, but you must instruct Acrobat to honor that structure. To use the order specified 
by the InDesign document’s structure, select all the pages in the Acrobat’s Page 
Thumbnails pane, choose Page Properties from the Options menu, then select Use 
Document Structure for the tab order. 

• Run the Acrobat accessibility check 
o After these steps are completed, confirm that the document has no errors by 

choosing Full Check from the Acrobat accessibility tools. 

Creating an accessible PDF 

Add Export Tagging instruction to paragraph styles 
Defining export tags in a paragraph style creates an association between the text using that style 
and its role in the semantic structure of the PDF document. You can set any paragraph style to one 
of eight basic PDF tags. 

PDF tag Applied to 

<P> Any standard, narrative paragraph of text that is not a heading 

<H1> through <H6> A heading that reflects the document's organizational hierarchy 

<Artifact> Any page content that the screen reader should ignore 

If you do not assign export tags, all styles default to Automatic. The Automatic setting honors any 
style-to-XML tagging that might have been established in an older XML-based workflow. If no style-
to-XML relationships have been established, the Automatic setting translates them to a P tag in 



Acrobat. There is no additional parsing of the document to determine a heading structure. Because 
of this default behavior, explicitly assigning export tags to paragraph styles is an essential 
accessibility step. 

You set the Export Tagging options for a style in the Export Tagging area of the Paragraph Style 
Options dialog. If you use InDesign’s Bullets and Numbering feature, bulleted and numbered lists 
are tagged as unordered or ordered lists, respectively, and converted automatically, depending on 
the options selected in the export process. Manually created lists are not recognized as list items. 

 
Figure 2. Export Tagging setting in InDesign. 

InDesign’s Export Tagging settings allow two different tagging schemes. The options for EPUB and 
HTML have no bearing on the options for PDF, which must be set independently. Although the role 
assigned to a specific paragraph will likely be similar between the two, PDF has fewer options and 
no custom tagging options. 

If a project already has styles, you can map all styles in the document in one step by choosing Edit 
All Export Tags in the Paragraph Styles panel menu. In the resulting dialog, select the PDF option 
and assign PDF tags from the pull-down menus in the right column to the paragraph style names in 
the le column. 

In Acrobat, the Role Map reflects the associations made between the InDesign Header style and 
the H1 tag and between the Section headers style and the H2 tag, both of which were assigned in 
the Export Tagging options for the respective styles in InDesign. 

Add Alt text using Object Export Options 
Images in an accessible PDF document require alternative text so that the image can be described 
by a screen reader or assistive device. You can add alt text for an image through the XML Structure 
pane or with Object Export Options (Object > Object Export Options). This dialog is non-modal, so 



it can remain open as you work in the document, allowing you to move quickly from image to image 
and assign metadata without repeatedly closing and opening the dialog. 

The Object Export Options dialog has three tabs—Alt Text, Tagged PDF, and EPUB and HTML. Alt 
Text applies to both the PDF and EPUB/HTML workflows. You can generate the alt text from the 
document’s XML structure (if any exists) or the image’s XMP metadata (if present). Or you can 
directly add the alt text to the specific instance of the image in the layout by selecting Custom from 
the Alt Text Source pull-down menu. 

The XMP metadata for an image is available as potential alt text in InDesign. Specifying alt text from 
XMP metadata is the best choice in most cases, because the link between the alt text and the 
metadata in the file is dynamic. If the metadata changes, alt text is updated when you update the 
image link in your InDesign document. Not including alt tags for all of your images will result in 
errors later in the workflow when you run the Acrobat accessibility check. 

In the final PDF document, alt text appears as a tooltip when the user hovers over an image. The alt 
text is also read as a description of the image when Acrobat’s Read Out Loud feature is used, or 
when the PDF is read by an assistive device or screen reading software. 

Anchor Images into the text flow 
When images are placed on a page in a print layout, they do not necessarily need to be placed 
adjacent to the copy that refers to them. For sighted users, it’s not unusual for text to contain 
references to an image located elsewhere in the document. However, when you’re establishing a 
flow of content for an accessible PDF document, those images should be described at the 
appropriate point within the flow. InDesign allows you to place a machine-readable reference to the 
image in the text by anchoring the graphic frame containing the image to an appropriate location 
within the text frame. 

Each InDesign frame and object group displays a small blue square on its top edge. To anchor an 
object in an accessible location in the text flow without changing the original position of the object, 
click and hold the blue square, and then drag it to the desired location within the text and release. 
The blue square changes to an anchor icon indicating that the object is anchored. 

 
Figure 3. To anchor an object, drag the blue square on a frame (left) to the desired location in the text. When anchored 
(right), the blue square becomes an anchor icon. 



In the PDF file, the Figure tag for the anchored image appears within the appropriate <body_copy> 
tag in the main article and will be referenced and described by its alt text at that point. 

Establish a reading order with the Articles panel 
InDesign’s Articles panel allows you to establish a document’s content reading order for Acrobat 
entirely within InDesign without using the XML structure pane. Acrobat understands this order and 
will follow it in the exported PDF once you instruct it to do so in Acrobat. 

To establish the reading order in InDesign, open the Articles panel (Window > Articles) and click 
the desired object or objects on the page to include in the article. Drag the objects into the Articles 
panel, and release the mouse. Objects are listed in the order that you click them. Name the article 
when prompted to, or keep the default name Article 1. Alternatively, you could use Select All 
(Cmd/Ctrl-A) and click the New Article button at the bottom of the Articles panel to add all selected 
objects and create a new article in one step (you can rename it later). Objects are given default 
names based on the object’s type and content. If an object has already been given a specific name 
in the Layers panel, it retains that name in the Articles panel. 

 
Figure 4. Create new article. 

When adding a new article to the InDesign Articles panel, you must select Include When Exporting 
(the default) for the article to be properly tagged and ordered in the PDF file. 

Organize your content in the Articles panel by dragging an item within an article up or down until all 
items are in the desired order. The reading order is from top to bottom. Reordering in the Articles 
panel does not affect the position or appearance of items on the InDesign page. You can also add 
elements from different parts of your layout into an existing article by dragging them from the layout 
into the Articles panel, or selecting them and choosing Add Selection to Selected Articles from the 
Articles panel menu. To break up your content’s structure appropriately, you can create multiple 
articles. 

Add bookmarks, cross-references, and hyperlinks for navigation 
Cross-references, hyperlinks, and bookmarks are conveniences to sighted readers, but are also 
essential navigation tools for the visually impaired. These navigation mechanisms are the means by 
which users with disabilities move through a document and get an overview of its content and how 
that content is organized. A table of contents (TOC) generated in InDesign can add bookmarks 
automatically when the Create PDF Bookmarks option is selected in the Table of Contents dialog. 
You can also add custom bookmarks independent of a dynamic TOC in the Bookmarks panel 
(Window > Interactive > Bookmarks). You can link bookmarks to either text anchors (bookmarks 



created when specific destination text is selected) or pages (bookmarks created when viewing a 
page in InDesign with no text selected). 

You can arrange bookmarks hierarchically in the InDesign Bookmarks panel as well as nest specific 
bookmarks under broader categorical bookmarks for a clearer indication of a document’s distinct 
sections. When exported to PDF with the proper settings, the InDesign bookmarks and their 
organizational structure are matched exactly in the Acrobat Bookmarks pane and work as clickable 
links to the appropriate content. 

Hyperlinks—either to external locations like websites or to in-document locations like text 
anchors—provide additional navigation points on a more micro level that might not be appropriate 
or necessary in the document’s bookmark structure. PDF hyperlinks are created upon export for 
links created in the InDesign Hyperlinks panel, and any cross-references established using the 
InDesign Cross-references feature. Cross-references created in InDesign translate automatically to 
hyperlinks in the exported PDF document.  

Add interactive form elements 
With form-creation features in InDesign, there is support for tagging of certain interactive elements, 
such as form fields and buttons. An exported InDesign form contains the necessary <Annot> 
(annotation) tags to make it accessible in the resulting PDF document. 
InDesign supports creation of checkboxes, combo and list boxes, radio buttons, text fields, and 
signature fields, all of which are created in the Buttons and Forms panel (Window > Interactive > 
Buttons and Forms). Each form element has both a name value and a description value that must 
be part of its definition. The description is essential for accessibility, because it acts as both the 
tooltip and as the alt text for the form item. The form can also have a visible label (for example, 
Name, Company, Phone) on the page, but as a user tabs from field to field or box to box, only the 
information assigned to the form element is read out; the adjacent text is not. 

It’s essential to make sure that the tab order of the various form elements (including Submit 
buttons) is established correctly prior to export so that as the user tabs through—or is guided with 
an assistive device — the form fields and options, the user is advanced to each step in the proper 
order. When your form is designed and its functionality is defined in the Buttons and Forms panel, 
review the Tab Order dialog (Object > Interactive > Set Tab Order) to confirm that all form 
elements are listed in the proper order. Make any necessary adjustments or corrections using the 
Move Up and Move Down buttons. Alternately, you can add your form elements to the Articles panel 
in the appropriate tab order, but double-checking the order in the Tab Order dialog is still a good 
quality control measure. The Tab Order dialog lists the order that a user moves through a form with 
either the Tab key or an assistive device from top to bottom. 

Add file metadata to the InDesign document 
Accessible PDF documents require, at a minimum, a document title and a brief description of the 
contents. This information is stored in the file’s metadata, which you can access from the 
Document Properties dialog in Acrobat. The metadata can (and should) originate in the InDesign 
document’s File Information dialog (File > File Info), where it can be modified and updated easily 
and preserved each time a new PDF document is created. 



Export for accessibility 
After you prepared the document for accessibility in InDesign, you are ready to export it (File > 
Export) to PDF using the Adobe PDF (Interactive) or Adobe PDF (Print) format options. Which PDF 
type you choose depends upon whether or not your document contains interactive elements such 
as forms, buttons, audio, or video. Although the formatting is the same for both PDF types, they 
offer different options in their respective dialog boxes. The Adobe PDF (Print) format exports 
bookmarks and hyperlinks but not buttons, audio, video, or animation. You can only opt to include 
the appearance of these interactive elements — not their functionality — or to not include them at 
all. 

To be accessible, the exported PDF must be tagged, so make sure you select the Create Tagged PDF 
option in the Export dialog box for either PDF type. In the Export to Interactive PDF dialog, select the 
Use Structure for Tab Order option to save yourself that step in Acrobat later on. To activate 
bookmarking, hyperlinks, cross- references, and buttons, set the Forms and Media option to 
Include All. All other settings in the dialog are optional and subject to your specific needs or 
preferences. To automatically open the PDF document as soon as the export is completed, select 
the View After Exporting option. You can then move on to the final few steps required in Acrobat. 

Review the exported PDF in Acrobat 
As with any published document, it’s always a sound policy to review the final version for any 
potential unexpected results. Looking at the tagging structure in the Acrobat Tags pane may help 
foster a better understanding of the connection between your InDesign preparation and the final 
PDF document. 

The Acrobat Order pane might not match the order you establish in InDesign’s Articles panel, and it 
doesn’t necessarily reflect the reading order used by assistive technologies and the Acrobat Read 
Out Loud feature. Only the Tags panel ordering, as determined by the arrangement of content in the 
InDesign Articles panel, represents the reading order of the PDF content, regardless of the 
sequence shown in the Order panel or in the Acrobat Reflow mode. 

Assign a document language in Acrobat 
After you’ve created the PDF file, you can move to Acrobat to complete the remaining steps to make 
the PDF document accessible. The first step is to set the document’s language in the Advanced tab 
of the File Properties dialog (File > Properties). InDesign has no corresponding setting, so you must 
set the language in Acrobat. It’s also recommended that you set the document to display its title in 
the document window’s title bar rather than its filename. You can make that change in the Initial 
View options of the Document Properties dialog. 

Specify the tab order 
The structure created in the InDesign Articles panel is exported to the PDF file, but it is not 
automatically set as the order followed when tabbing through interactive elements like hyperlinks 
and form fields. You must establish the tab order the Acrobat Page Thumbnails pane (View > 
Show/Hide > Navigation Panes > Page Thumbnails). Highlight all of the documents page 
thumbnails, and then choose Page Properties from the Options menu in the Page Thumbnails pane. 



In the Tab Order area of the Page Properties dialog, change the content order from Unspecified to 
Use Document Structure. 

If you’ve exported your document as an Interactive PDF file and selected the Use Structure for Tab 
Order option, you can skip this step. Because print version of the InDesign Export Adobe PDF dialog 
does not have this option, you must select it in Acrobat. 

Run the Acrobat accessibility check 
From the Acrobat Tools pane, expand the Accessibility options (View > Tools > Accessibility), and 
select Full Check. Make sure that the Create Accessibility Report option is selected. This option 
shows whether the document is error free, and if not, details the problems. 
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